Back to overview
Downtime

Upstream service provider issues

Oct 20 at 03:49pm EDT

Resolved
Oct 20 at 09:54pm EDT

Upstream issues have been resolved and service is restored.

Updated
Oct 20 at 09:06pm EDT

The underlying outage with our cloud provider (AWS) has been resolved. We are still waiting for service to fully restore as other upstream providers recover.

Updated
Oct 20 at 04:18pm EDT

We're starting to see things recover. We will continue to monitor and update as we see things come back online.

Created
Oct 20 at 03:49pm EDT

We're currently experiencing an outage with an upstream service provider, which is making our application unavailable to users. We are monitoring the situation and will provide updates when we've established a timeline for recovery.